Results 1 to 3 of 3

Thread: Ridiculous Lag since new server opening

Hybrid View

  1. #1
    Join Date
    Jun 2009
    Location
    Coming soon to a npc near you
    Posts
    78

    Default Ridiculous Lag since new server opening

    Hi,
    I've searched for a thread voicing complaints about the current problems in game since the new server opened, but I haven't found any (ok I didn't search THAT hard), so decided to pose my question here. Can any of TPTB advise when we can get back to business as usual within game? Here are some of the problems I'm experiencing:
    1) Currently troops are sticking at the return point
    2) the spinning clock of lag doesn't go away for 2mins or more
    3) lag seems worse when trying to attack, defend or comment - actually trying to do anything results in the clock
    4) have had my account restart twice during one "stick" episode

    any information at all will be greatly appreciated. server: SS67
    Last edited by Persephone; 09-22-2014 at 10:08 PM.

  2. #2

    Default





    my fleet feet just aint very fleet any more
    Last edited by TECH-ss48; 09-22-2014 at 05:55 PM.

  3. #3

    Default

    i'm using a dynamic IP and i think other perssons are playing this game, but as i heard on the game the maximum of players for ip is 3. So i have to stop playing this game after 5 years of being here everyday?!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •